Added build target
[rrq/overlay-boot.git] / Makefile
index bc4f1ccb7743e81ac797b50620462f2d7d265783..1f7dbe878f4311ecb7bf7005daa7c3cc4261fa78 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -39,7 +39,7 @@ $(ETCDIR)/subhosts.conf: subhosts.conf | $(ETCDIR)/
 
 # Generic rule: a local .8 file depends on the same .8.adoc file, if any
 $(MAN8FILES): %: %.adoc
-       a2x -d manpage -f manpage $^
+       asciidoctor -b manpage $^
 
 # Generic rule: an installed MAN8FILE file depends on a local the
 # same, and that the installation directory exists
@@ -71,3 +71,7 @@ BUILDPACKAGE = -us -uc --build=full -Iolle
 deb:
        dpkg-buildpackage $(BUILDPACKAGE)
 #      PREFIX= INCLUDE_PREFIX=/usr
+
+build:
+       gbp buildpackage --git-debian-branch=debian --git-export-dir=build \
+                         --git-ignore-new